Content viewing report showing no data

I wanted to use the content viewing report in one of our SharePoint Online sites to track the views. However, when I clicked Content viewing on the View Auditing Reports page, it gave me an error – report contains no data. My first reaction was going to the audit log settings page to make sure the settings are correct. Noticed the Opening or downloading documents, viewing items in lists, or viewing item properties option is not available in Documents and Items section.

aduitsettings

I found out this type of report is not available for SharePoint Online.  One of Microsoft’s article pointed out that “In SharePoint Online, this report will be blank as these events are not captured during auditing.”

Why? A potential reason is, from another Microsoft’s article, “For SharePoint Server 2013, we recommend that you only select the Opening or downloading documents, viewing items in lists, or viewing item properties event when absolutely necessary. This option is likely to generate a large number of events that will potentially degrade the performance and other aspects of your site collection(s).”

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s